excel - "blbuvzdorná" tabulka

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Rexlopek
nováček
Příspěvky: 3
Registrován: listopad 17
Pohlaví: Muž

excel - "blbuvzdorná" tabulka

Příspěvekod Rexlopek » 07 lis 2017 15:07

Ahoj,
možná se vám to bude zdát jednoduché, ale já si s tím nevím rady. Mám obyčejnou tabulku, kde v řádcích jsou nějaké položky a ve sloupcích nějaký popis a hlavně počet. Poslední řádek tabulky je klasické slovo: "celkem" a suma posledního sloupečku.
Ten celkový součet bych potřeboval aby se mi zároveň propisoval do jiné buňky. Jenže do té tabulky nebudu psát sám a potřeboval bych, aby byla trochu "blbuvzdorná", kdyby třeba mi ten poslední řádek někdo smazal a pak zase vytvořil, nebo zkrátka něco provedl, aby to pořád fungovalo. Napadlo mě, jestli by nešlo třeba porovnat, jestli není v sloupci A:A třeba to klasické slovo "celkem" a pokud ano opsalo by to buňku v sloupci D na té samé řádkové pozici, ale nevím, jak to udělat. Nebo nenapadá někoho něco elegantnějšího? : )
Nemáte oprávnění prohlížet přiložené soubory.



Reklama
MePExG
Level 1
Level 1
Příspěvky: 84
Registrován: srpen 16
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod MePExG » 07 lis 2017 20:16

...
Nemáte oprávnění prohlížet přiložené soubory.
Naposledy upravil(a) MePExG dne 08 lis 2017 14:37, celkem upraveno 1 x.

Rexlopek
nováček
Příspěvky: 3
Registrován: listopad 17
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod Rexlopek » 08 lis 2017 06:49

Dík za řešení, ale je o ničem. Smazal jsem poslední řádek, dopsal pod to řádek navíc a nepřipočítalo to nic.

Uživatelský avatar
elninoslov
Level 1.5
Level 1.5
Příspěvky: 140
Registrován: červen 13
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod elninoslov » 08 lis 2017 07:49

Blbuvzdorná tabuľka s umelou inteligenciou neexistuje. Dajte zrátať celý stĺpec

Kód: Vybrat vše

=SUM(D:D)
=SUMA(D:D)

ale to Vám nevyhovuje, lebo niekto môže napísať pod tabuľku iné dáta, ktoré do tabuľky nepatria.
Ak dáte vyhľadávať koniec tabuľky, podľa pozície "celkem" - to môže niekto zmazať.

Kód: Vybrat vše

=MATCH("celkem";A:A;0)
=POZVYHLEDAT("celkem";A:A;0)

Ak dáte hľadať koniec tabuľky podľa prvého prázdného riadku napr. v A:A

Kód: Vybrat vše

=MATCH(TRUE;ISBLANK(A:A);0)-1
=POZVYHLEDAT(PRAVDA;JE.PRÁZDNÉ(A:A);0)-1

rovnako nebude fungovať, lebo niekto môže vynechať riadok, a potom to bude rátať iba po prvú medzeru.
Ak dáte spočítať počet hodnôt v niektorom stĺpci, napr. A:A

Kód: Vybrat vše

=COUNT(A:A)
=POČET(A:A)

tak to rovnako nebude sedieť, lebo niekto môže vynechať riadok, alebo môže byť pod tabuľkou niečo čo tam nepatrí.
Ak zamknete bunky, ktoré chcete zachovať (H2 a A22:D22), pôjde vkladanie riadkov a rozsah v H2 sa sám posunie, nepôjde ale mazanie riadku (aspoň u mňa).

Čo ak niekto zmaže celý stĺpec? Čo ak bude písať hodnoty vedľa do stĺpca ? (to sa dá zamknúť) Čo ak tam napíše písmená, namiesto čísel ? (Ošetriť možno cez Overenie dát)
...

Je niečo iné, keď sa na to pozrie ľudské oko, a okamžite mozog vyhodnotí čo tam patrí a čo nie, ako keď to má vedieť Excel.

Treba u Vás zaviesť medzi ľuďmi, čo budú s tým pracovať, nejakú osvetu a nejakú základnú kultúru práce s dátami. Lebo hľadanie všetkým možných riešení na všetky možné eventuality, ktoré môžu nastať z rúk nepoučeného človeka (človek je kreatívny), je nepomerne ťažšia, ako poučenie daných ľudí.

Skúste to trochu ešte upresniť.

Michremi
nováček
Příspěvky: 15
Registrován: listopad 17
Pohlaví: Nespecifikováno

Re: excel - "blbuvzdorná" tabulka

Příspěvekod Michremi » 08 lis 2017 12:00

Mě zase zprvu napadlo sečíst celý sloupec a dělit dvěma =SUMA(D:D)/2
anebo aby to bylo trošku ošetřené udělat tohle =(SUMIFS(D:D;A:A;"<>"))/2

funguje to tak, že to sečte všechno v posledním sloupci, pokud v sloupci jedna jsou nějaké znaky, tedy slovo celkem, ale samozřejmě, stačí si pod tu tabulku začít psát vlastní poznámky, výpočty a zase to jde do háje

Uživatelský avatar
atari
Level 4.5
Level 4.5
Příspěvky: 1663
Registrován: říjen 08
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod atari » 09 lis 2017 09:23

Stačí zamknout list a povolit editaci.
Nemáte oprávnění prohlížet přiložené soubory.

Uživatelský avatar
elninoslov
Level 1.5
Level 1.5
Příspěvky: 140
Registrován: červen 13
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod elninoslov » 09 lis 2017 09:35

To ale neumožňuje meniť počet riadkov, čo som z popisu vydedukoval, že asi bude potreba.

Uživatelský avatar
atari
Level 4.5
Level 4.5
Příspěvky: 1663
Registrován: říjen 08
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod atari » 09 lis 2017 10:17

Rexlopek píše:potřeboval bych, aby byla trochu "blbuvzdorná", kdyby třeba mi ten poslední řádek někdo smazal a pak zase vytvořil, nebo zkrátka něco provedl,

Podle zadání je nežádoucí, aby někdo mazal a přidával řádky.

Uživatelský avatar
elninoslov
Level 1.5
Level 1.5
Příspěvky: 140
Registrován: červen 13
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod elninoslov » 09 lis 2017 10:28

Tak to som teda blbo pochopil. Mňa zmiatla práve následná veta (po Vami citovanej), keď by dotyčný rád zisťoval na akej pozícii sa nachádza "Celkem". V tom prípade je to úplne jednoduché, a riešenie ste uviedol. Prípadne sa dá v H2 napevno odkazovať na D22, teda =$D$22
Základ je v pochopení otázky :)

Uživatelský avatar
atari
Level 4.5
Level 4.5
Příspěvky: 1663
Registrován: říjen 08
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod atari » 09 lis 2017 10:39

Tak doufám, že se k tomu tazatel vyjádří, a příště napíše jednoznačné zadání !!!

Rexlopek
nováček
Příspěvky: 3
Registrován: listopad 17
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod Rexlopek » 10 lis 2017 08:21

Má se to tak, že ta tabulka bude volně přístupná na sdíleném disku a každý si ji bude moci stáhnout a vpisovat data a tedy přidávat řádky podle toho, kolik bude potřeba. Ten konečný výsledek se pak bude propisovat zase do jiných tabulek, na které je to navázané. Proto se bojím, že třeba umažou konec, přidají řádky, pak si ho třeba zase vytvoří, jenže ty navazující tabulky už nebudou fungovat...
Asi bude nejlepší jak mi poradil elninoslov, poučit pořádně ty lidi.

Uživatelský avatar
elninoslov
Level 1.5
Level 1.5
Příspěvky: 140
Registrován: červen 13
Pohlaví: Muž

Re: excel - "blbuvzdorná" tabulka

Příspěvekod elninoslov » 10 lis 2017 09:57

-Normálne si vytvorte Definovaný názov s menom napr. "CELKEM" a vzorcom

Kód: Vybrat vše

=SUM(list1!$D:$D)
=SUMA(list1!$D:$D)

-Do H2 dajte vzorec

Kód: Vybrat vše

=CELKEM

-V naväzujúcich tabuľkách čítajte hodnotu Definovaného názvu CELKEM. Môžu pridávať a mazať riadkov koľko chcú. Dokonca môžu zmazať aj riadok 2, v ktorom je súčet, to nevadí lebo v tých iných tbl voláte názov CELKEM.
-Aj tak ale musia zachovať nejakú "kultúru zadávania dát"


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Excel: turnajova tabulka
    od p.bublik » 03 říj 2017 21:34 » v Kancelářské balíky
    1
    718
    od atari
    03 říj 2017 21:43
  • Tabulka v Excelu
    od Betty80 » 14 srp 2017 20:22 » v Vše ostatní (sw)
    0
    420
    od Betty80
    14 srp 2017 20:22
  • Exel tabulka s obrázky
    od vlakouš » 17 zář 2017 16:23 » v Kancelářské balíky
    0
    373
    od vlakouš
    17 zář 2017 16:23
  • Aktualizační tabulka windows
    od lamond » 01 srp 2017 14:25 » v Windows 10, 8, 7, Vista, XP…
    1
    205
    od Microsheep
    01 srp 2017 14:28
  • Kontingenčí tabulka z více listů
    od vonv » 25 črc 2017 08:19 » v Kancelářské balíky
    0
    326
    od vonv
    25 črc 2017 08:19

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 1 host