Čísla před znaménkem mínus Vyřešeno

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

luko02420
Level 1.5
Level 1.5
Příspěvky: 119
Registrován: únor 12
Pohlaví: Nespecifikováno

Čísla před znaménkem mínus

Příspěvekod luko02420 » 23 lis 2018 09:35

Dobrý den, potřeboval bych opět poradit.
Potřeboval bych rozdělit znaky v bunce tak, aby mi zůstalo to co je před znaménkem mínus .
Použítí funkce zleva se mi nehodí, protože ne vždy je před znaménkem minus 7 znaků.
Oddělit to co je za známenkem minus pomoci fce "část a najít" umím ale obráceně nevím jak na to.
Zápis vypadá takto "A500400-14".
Potřebuji aby me zustalo " A500400"
Děkuji za pomoc.



Reklama
Zivan
Level 3.5
Level 3.5
Příspěvky: 838
Registrován: leden 10
Pohlaví: Nespecifikováno

Re: Čísla před znaménkem mínus

Příspěvekod Zivan » 23 lis 2018 10:14

Jednoduše použiješ ČÁST a NAJÍT a vezmeš to co je od začátku, do nalezené pomlčky (-1, protože tu pomlčku nechceš).

V českém Excelu bez ošetření chyby (v A1 je ten text s pomočkou):
=ČÁST(A1;1;NAJÍT("-";A1)-1)

A s ošetřením, když v textu pomlčka chybí:
=KDYŽ(JE.CHYBHODN(NAJÍT("-";A2));A2;ČÁST(A2;1;NAJÍT("-";A2)-1))

luko02420
Level 1.5
Level 1.5
Příspěvky: 119
Registrován: únor 12
Pohlaví: Nespecifikováno

Re: Čísla před znaménkem mínus  Vyřešeno

Příspěvekod luko02420 » 23 lis 2018 11:05

Ježiši já jsem trol. Dával jsem fce NAJÍT do startu místo do počtu znaků.
Děkuji moc
Zavírám


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Nelze psát čísla v kolonce heseo
    od patkopecky » 19 úno 2018 23:58 » v Windows 10, 8, 7, Vista, XP…
    0
    330
    od patkopecky
    19 úno 2018 23:58
  • Nelze psát čísla v kolonce heslo
    od patkopecky » 20 úno 2018 00:12 » v Windows 10, 8, 7, Vista, XP…
    2
    476
    od hroch123
    20 úno 2018 09:05
  • U Fortnite a Darwin Project nefungují horní čísla
    od Extram258 » 25 říj 2018 20:23 » v Hry
    0
    741
    od Extram258
    25 říj 2018 20:23

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 0 hostů