Excel - funkce Když, dvě kriteria Vyřešeno

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

deuzsen
nováček
Příspěvky: 6
Registrován: duben 20
Pohlaví: Muž

Excel - funkce Když, dvě kriteria

Příspěvekod deuzsen » 28 dub 2020 15:03

Zdravím,

Snad nebude můj dotaz příliš triviální. Co potřebuji? Potřebuji nastavit, aby cílová buňka uměla rozeznat obsah dvou oblastí dat a podle toho zobrazit správný text.
Pokud oblast 1 je prázdná, tak se v cílové buňce zobrazí "+DPH". Pokud obsahuje cokoliv, tak potom se zobrazí v cílové buňce "bez DPH". Můj vzorec pro tohle je KDYŽ(POČET2(A2:C6);"+DPH";BEZ DPH"))
A nyní potřebuji přidat k tomuto vzorci, aby cílová buňka uměla posoudit, když další buňka bude obsahovat "SK", tak potom "bez DPH" a když cokoliv jiného, tak potom "+ DPH".
Ale zároveň v případě, že první oblast obsahuje cokoliv, ale druhá oblast neobsahuje SK, tak platí "bez DPH". Tady jsem se dopracoval ke vzorci KDYŽ(POČET2($B$1);"bez DPH";KDYŽ($B$2="SK";"bez DPH";"+ DPH")), jenže ten funguje jen pokud druhá oblast obsahuje jen to SK, ale pokud napíšu třeba "test, SK", už je výsledek špatný.

Příklad:
Oblast 1:
Oblast 2:
výsledek= "+ DPH"

Oblast 1:
Oblast 2: Test, SK
Výsledek aby byl = "bez DPH"

Oblast 1: Cokoliv
Oblast 2: Test, SK
Výsledek = "bez DPH"

Děkuji za pomoc a vysvětlení

Dodatečně přidáno po 14 minutách 43 vteřinách:
Tak jsem právě našel řešení. =KDYŽ(POČET2($B$1);"bez DPH";KDYŽ(JE.ČISLO(HLEDAT("SK";$B$2));"bez DPH";"+ DPH"))

Jakobych nic nepsal.

Díky



Reklama
Uživatelský avatar
mmmartin
Moderátor
Master Level 9
Master Level 9
Příspěvky: 8337
Registrován: srpen 04
Bydliště: Praha
Pohlaví: Muž

Re: Excel - funkce Když, dvě kriteria  Vyřešeno

Příspěvekod mmmartin » 28 dub 2020 17:43

Nestačí napsat Jako bych nic nepsal, je také slušné označit téma jako vyřešené. ;)


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Excel - složená funkce - prosím o kontrolu
    od Čejka » 11 črc 2019 00:24 » v Kancelářské balíky
    8
    1318
    od Čejka
    11 črc 2019 18:05
  • Excel - rozdělení titulu/jména/příjmení pomocí funkce
    od fraxy » 15 lis 2019 14:35 » v Kancelářské balíky
    2
    744
    od fraxy
    15 lis 2019 18:03
  • funkce H/W S/W v prehravaci
    od symetrala » 28 zář 2019 19:21 » v Multimédia (filmy, hudba, CDs/DVDs)
    3
    1797
    od richchie
    29 zář 2019 09:30
  • Smart Box O2 a funkce mesh
    od Jsimi » 14 úno 2020 17:05 » v Sítě - hardware
    1
    657
    od ITCrowd
    14 úno 2020 17:17
  • Klávesy na klávesnici mají jiné funkce
    od potok9 » 03 kvě 2020 18:11 » v Windows 10, 8, 7, Vista, XP…
    1
    176
    od Zivan
    03 kvě 2020 20:24

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 0 hostů