Excel - vlastní formát

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Story-Long
nováček
Příspěvky: 7
Registrován: květen 21
Pohlaví: Muž

Excel - vlastní formát

Příspěvekod Story-Long » 11 srp 2023 14:50

Zdravím všechny....

Nevíte někdo, jak na vlastní formát, když potřebuji toto:

Když bude hodnota v rozmezí od:
0-100 včetně - ukáže u čísla hodnotu ± 1 mm
>100 až do 200 včetně - ukáže u čísla hodnotu ± 2 mm
>200 až do 300 včetně - ukáže u čísla hodnotu ± 3 mm
>300 do nekonečna - ukáže u čísla hodnotu ± 4 mm


Napadlo mě tohle, ale nevím proč, nefunguje to:
[<=100]0" ± 1 mm";[>100]A[<=200]0" ± 2 mm";[>200]A[<=300]0" ± 3 mm";[>300]0" ± 4 mm"

.....asi jsou špatně "spojené" ty společné podmínky.
Ale zápis: [<=100]0" ± 1 mm";[<=200]0" ± 2 mm" - je funkční, ovšem není kompletní, dál se to zhroutí.

Nemáte s tím někdo zkušenosti?

Díky za radu

Reklama
Melvidor
Level 1
Level 1
Příspěvky: 85
Registrován: únor 17
Pohlaví: Nespecifikováno

Re: Excel - vlastní formát

Příspěvekod Melvidor » 11 srp 2023 15:45

Logická spojka A má v Excelu jinou syntaxi.
=KDYŽ(A(200<A3;A2<300);"+- 2mm”; jiná_podm)

Kromě první podmínky (je 0-100 - ne? Je <=200 - ne? Je <=300.... ) bys nemusel definovat spodní hranici.

Jestli budou jen 4 kritéria, tak bych použil když 3x. Nevím jestli excel má přímo na tvůj problém extra funkci.

Uživatelský avatar
elninoslov
Level 2.5
Level 2.5
Příspěvky: 366
Registrován: červen 13
Pohlaví: Muž

Re: Excel - vlastní formát

Příspěvekod elninoslov » 12 srp 2023 01:18

Skúste PF
Nemáte oprávnění prohlížet přiložené soubory.

Story-Long
nováček
Příspěvky: 7
Registrován: květen 21
Pohlaví: Muž

Re: Excel - vlastní formát

Příspěvekod Story-Long » 14 srp 2023 10:11

Díky Melvidor - zkusím, vypadá to, že by to mohlo jet...
elninoslov - funguje to...jen jsem nepochopil jak to funguje....ve vlastní formát je slovo Všeobecný....ale?

Dodatečně přidáno po 3 minutách 34 vteřinách:
joo už vím....podmíněné formátování. Už vím...


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Excel - filtr na formát buňky + obsah
    od popcorn » 19 zář 2023 17:07 » v Kancelářské balíky
    0
    1611
    od popcorn
    19 zář 2023 17:07
  • Nový PC build (mainboard) - můžu jen swapnout disk s OS, nebo fakt musím format a čistou instalaci windows a všeho?
    od TomiDomi » 26 čer 2023 16:10 » v Rady s výběrem hw a sestavením PC
    2
    826
    od TomiDomi
    26 čer 2023 22:44
  • Excel a OneDrive
    od sginfo » 11 zář 2023 15:28 » v Kancelářské balíky
    16
    5728
    od mirekol
    20 říj 2023 08:31
  • Excel - problém se vzorci
    od honzzicek » 28 čer 2023 21:45 » v Kancelářské balíky
    2
    1466
    od honzzicek
    01 črc 2023 08:57
  • Excel - funkce když
    od Martyn20 » 13 črc 2023 11:56 » v Kancelářské balíky
    5
    2089
    od mmmartin
    13 črc 2023 18:44

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 2 hosti