excel - práce se staženými daty

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Uživatelský avatar
Stene
Level 6
Level 6
Příspěvky: 3112
Registrován: únor 09
Bydliště: Jihlava
Pohlaví: Muž

excel - práce se staženými daty

Příspěvekod Stene » 02 srp 2019 20:40

Ahoj. Předem upozorním, že s excelem nejsem žádný velký kamarád - proto poprosím, pomaličku na mě :D :D

O co jde... Do excelu stahuji aktuální ceny kryptoměn z coinmarketcap. Když s cenou daného coinu chci pracovat dál a například ho vynásobit, tak to nejde.. Problém je v tom, že stažená hodnota je v tabulce v uvozovkách - viz příloha
Když nechám vyhodnotit chybný vzorec, tak mnou zapsaný vzorec =SUMA(E2*5) vypadá po vyhodnocení vzorce následovně =SUMA("10482,51134"*2) - překáží uvozovky :-(

Děkuji za trpělivost se mnou :-)

Bez-názvu-1.jpg
Nemáte oprávnění prohlížet přiložené soubory.



Reklama
Uživatelský avatar
Eddie75
nováček
Příspěvky: 28
Registrován: leden 19
Pohlaví: Muž

Re: excel - práce se staženými daty

Příspěvekod Eddie75 » 02 srp 2019 21:34

Ahoj,
číslo v tabulce ti to bere jako text. Problém vidím zejména v desetinné tečce/čárce. Standardně, pokud je desetinné znaménko správné, stačí hodnotu vynásobit jedničkou, případně funkcí HODNOTA(). Vynásobení pětkou vy mělo fungovat obdobně. Tady bude asi potřeba buď změnit v nastavení desetinné znaménko, nebo použít funkci DOSADIT().

Příklad (číslo, které zpracováváme, je v buňce A1, chceme jej vynásobit např. 5):
=HODNOTA(DOSADIT(A1;".";","))*5

P.S.: v tomto případě bychom se měli obejít i bez funkce hodnota, takže by mělo stačit =DOSADIT(A1;".";",")*5 - převod na formát čísla nám zajistí právě to vynásobení pětkou
P.P.S.: funkce suma je součtová, prosté výpočty stačí dát za rovná se. Nicméně výsledek ti vyleze stejný (sčítáš součin čísel s ničím) ;)
PC: Intel Core i7-9700K | MSI GeForce RTX 2070 Super Gaming X Trio | MSI MPG Z390 Gaming Pro Carbon AC | 500 GB + 1TB NVMe SSD WD Black | 2x16 GB RAM HyperX Predator RGB DDR4 3200 CL16 | NZXT X62 Kraken | Corsair RM850x v2 | NZXT S340 Elite | NZXT HUE2 + 2x RGB AER HF | W10Home
NAS: Synology DS218 | 2x 4TB Segate IronWolf Pro


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • Excel VBA - práce s listy
    od mihalan » 09 zář 2019 17:06 » v Kancelářské balíky
    2
    681
    od mihalan
    10 zář 2019 15:56
  • Práce s 3D SW
    od Steellady » 30 říj 2019 16:46 » v Nabídka práce
    0
    395
    od Steellady
    30 říj 2019 16:46
  • Hledám Grafika(jednoducha prace)
    od LipinacikCZ » 08 kvě 2019 16:23 » v Design a grafické editory
    0
    662
    od LipinacikCZ
    08 kvě 2019 16:23
  • Notebook - 17K (škola, práce)
    od popcorn » 31 črc 2019 09:16 » v Rady s výběrem hardwaru a sestavením PC
    7
    443
    od popcorn
    15 srp 2019 21:58
  • Notebook do školy/práce/občasné hry do 36000
    od Qwasyx0 » 20 bře 2019 22:57 » v Rady s výběrem hardwaru a sestavením PC
    0
    343
    od Qwasyx0
    20 bře 2019 22:57

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: Brandwatch [Bot], CommonCrawl [Bot] a 2 hosti