Excel - podmíněné formátování s VLOOKUP Vyřešeno

Programy pro práci v kanceláři (Word, Excel, Access…=>Office)

Moderátor: Mods_senior

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 20 lis 2020 17:18

Ahoj,

prosím, potřebuji poradit s podmíněným formátováním s využitím vzorce - v tom případě VLOOKUP.
V příloze je příklad - Sheet 1 obsahuje tři řádky s hodnotami, které by se měly žlutě zvýraznit v případě, že tyto hodnoty mají "0" v druhém sloupci na Sheetu 2. Něco mám určitě špatně, protože to nefunguje. :-)

Předem díky moc za radu.
Nemáte oprávnění prohlížet přiložené soubory.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Reklama
MePExG
Level 2
Level 2
Příspěvky: 193
Registrován: srpen 16
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod MePExG » 20 lis 2020 19:25

Ten vzorec bol nefunkčný (v podmienenom formáte), lebo bol uzavretý v apostrofoch, alebo uvodzovkách. ...a čo prípad, ak hodnotu nenájde?
Nemáte oprávnění prohlížet přiložené soubory.

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 20 lis 2020 20:40

Já jsem ten vzorec psal bez uvozovek, ale Excel si je tam z nějakého důvodu doplnil. Každopádně díky - nicméně teď zkouším, jestli vzorec funguje i s pojmenovanou/definovanou oblastí. Na Sheetu 2 jsem oblast zadal jako Table1. Když to pak zkouším zadat do vzorce, zase mi to píše chybu.

Když hodnotu nenajde neřeším, vždy tam bude, tohle je pouze příklad.

Test_cond_form_Excel.png
Nemáte oprávnění prohlížet přiložené soubory.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 23 lis 2020 09:02

up
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

cmuch
Level 4.5
Level 4.5
Příspěvky: 1540
Registrován: březen 11
Bydliště: Drsná Vysočina :D
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod cmuch » 23 lis 2020 11:57

Urav vzorec na =SVYHLEDAT($B3;Table1[#Vše];2;0)=0 / =VLOOKUP($B3;Table1[#All];2;0)=0

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 23 lis 2020 15:42

cmuch píše:Urav vzorec na =SVYHLEDAT($B3;Table1[#Vše];2;0)=0 / =VLOOKUP($B3;Table1[#All];2;0)=0


Bohužel to nefunguje - stále stejná chybová hláška.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod metropolisCZ » 25 lis 2020 10:23

Napadá někoho ještě něco, prosím?
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10

MePExG
Level 2
Level 2
Příspěvky: 193
Registrován: srpen 16
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP

Příspěvekod MePExG » 25 lis 2020 10:59

Podmienený formát nepodporuje odkazy na tabuľky. Buď si vytvorte stĺpec so vzorcom vyhľadania z tabuľky a na výsledok sa odvolajte v podmienenom formáte, alebo odkazujte na rozsah.

Uživatelský avatar
metropolisCZ
Level 2.5
Level 2.5
Příspěvky: 263
Registrován: srpen 12
Bydliště: Praha
Pohlaví: Muž

Re: Excel - podmíněné formátování s VLOOKUP  Vyřešeno

Příspěvekod metropolisCZ » 25 lis 2020 12:50

OK, díky za jasnou odpověď. Nechám to tedy tak, jak to mám - odkaz na rozsah. Vlákno zamykám.
GIGABYTE B85M-D3H-A | Intel Core i3-4170 | Kingston HyperX Fury 8GB DDR3 | ASUS DUAL-RX5500XT-O8G-EVO | Seasonic Focus GX 550 Gold | Win 10


  • Mohlo by vás zajímat
    Odpovědi
    Zobrazení
    Poslední příspěvek
  • formátování win
    od teichmann.ondrej » 09 dub 2021 15:23 » v Windows 10, 8, 7..
    20
    928
    od teichmann.ondrej
    12 dub 2021 16:25
  • Excel - odrážky
    od many11 » 07 lis 2021 21:58 » v Kancelářské balíky
    1
    202
    od elninoslov
    09 lis 2021 14:36
  • Napojení SQL na excel
    od Andrea320 » 05 srp 2021 14:39 » v Kancelářské balíky
    8
    517
    od Grimm
    10 srp 2021 13:25
  • Excel - Zoradenie
    od 28_nitro_28 » 18 srp 2021 09:34 » v Kancelářské balíky
    0
    308
    od 28_nitro_28
    18 srp 2021 09:34
  • Excel - derivace
    od FooDMasteR » 17 lis 2021 22:43 » v Kancelářské balíky
    2
    198
    od FooDMasteR
    18 lis 2021 21:02

Zpět na “Kancelářské balíky”

Kdo je online

Uživatelé prohlížející si toto fórum: CommonCrawl [Bot] a 0 hostů